暴跌神龙选股公式源码编程思路及告成率回测数据

​条件选股:暴跌神龙[日线]告成率测试

测试股票数:4577

共收回旗子灯号:100185告成旗子灯号:43666失利旗子灯号:56019未实现旗子灯号:500

旗子灯号收回率:90.08%匀称告成率:43.80%告成率达到50%的股票数有:39.56%

利润1总匀称:13.44%最大匀称利润1:  290.85%  最小匀称利润1: 0.00%

利润2总匀称:2.47%最大匀称利润2:  197.80%  最小匀称利润2:  -24.34%

编程思路:

HJ_1赋值:(2*开盘价+最低价+最自制)/4HJ_2赋值:5日内最自制的最低值HJ_3赋值:5日内最低价的最高值HJ_4赋值:(HJ_1-HJ_2)/(HJ_3-HJ_2)*27的5日指数移动匀称HJ_5赋值:HJ_4的3日指数移动匀称输出暴跌神龙:(开盘价)-1日前的(开盘价)>0.1ANDREF(开盘价,1)/9日前的开盘价<1.15ANDREF(开盘价,1)/6日前的开盘价<1.1ANDCOUNT(开盘价的5日俭朴移动匀称>开盘价的10日俭朴移动匀称,8)>5ANDREF(10日内开盘价的最高值/?日内开盘价的最低值的10),1)<1.15ANDEVERY(HJ_4>17,3)ANDEVERY(HJ_5>17,3)日过滤

公式源码:

HJ_1:=(2*CLOSE+HIGH+LOW)/4;

HJ_2:=LLV(LOW,5);

项目案例 35);">HJ_3:=HHV(HIGH,5);

HJ_4:=EMA((HJ_1-HJ_2)/(HJ_3-HJ_2)*27,5);

HJ_5:=EMA(HJ_4,3);

暴跌神龙:FILTER((CLOSE)-REF((CLOSE),1)>0.1 AND REF(CLOSE,1)/REF(CLOSE,9)<1.15 AND REF(CLOSE,1)/REF(CLOSE,6)<1.1 AND COUNT(MA(CLOSE,5)>MA(CLOSE,10),8)>5 AND REF(HHV(CLOSE,10)/LLV(CLOSE,10),1)<1.15 AND EVERY(HJ_4>17,3) AND EVERY(HJ_5>17,3),30);

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。